Commit 564eb61e authored by Fabrice  ALLAIN's avatar Fabrice ALLAIN
Browse files

Update setup.py

parent 4912d447
......@@ -207,7 +207,7 @@ def setup_package():
# Setuptools 18.0 properly handles Cython extensions.
'setuptools>=18.0',
'cython',
'matplotlib',
'matplotlib<3.0',
'numpy',
'pytest-runner'
],
......@@ -219,7 +219,7 @@ def setup_package():
'setuptools>=18.0',
'cython',
'numpy',
'matplotlib',
'matplotlib<3.0',
'docutils>=0.3',
'six>=1.10',
'Sphinx',
......@@ -321,7 +321,7 @@ def setup_package():
setup(**metadata)
for package in ('pip>=9.0', 'setuptools>=18.0', 'numpy>=1.11.0', 'matplotlib'):
for package in ('pip>=9.0', 'setuptools>=18.0', 'numpy>=1.11.0', 'matplotlib<3.0'):
if not is_installed(package):
print(textwrap.dedent("""
Installation needs {package}. You can install it via:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment