requirements-core.txt 630 Bytes
Newer Older
1
2
# modwsgi
mod-wsgi
3
# django and extensions
4
Django==2.2.1
5
6
7
8
django-extensions
django-formtools
django-debug-toolbar
django-allauth
9
# import scripts
10
pandas==0.25.0
11
12
openpyxl
xlwt
13
14
15
16
17
# web services
bioservices
bioblend
bs4
# libraries to compute PCA
18
scikit-learn==0.20.3 #later versions do not support Python<3.5
19
scipy==1.2.1 #Scipy >=1.3 does not support Python<3.5
20
21
matplotlib==2.2.3 #Matplotlib 3.0+ does not support Python 2.x, 3.0, 3.1, 3.2, 3.3, or 3.4.
# postgres driver
22
psycopg2-binary
23
git+https://gitlab.pasteur.fr/hmenager/django-diu.git#egg=django_diu
24
# openbabel is not installed from pip for now
25
26
#openbabel
django-crispy-forms