requirements-core.txt 673 Bytes
Newer Older
1
2
# modwsgi
mod-wsgi
3
# django and extensions
4
Django==2.2.1
5
6
7
8
django-extensions
django-formtools
django-debug-toolbar
django-allauth
9
django-celery-results==1.2.1
10
# import scripts
11
pandas==0.25.0
12
13
openpyxl
xlwt
14
15
16
17
18
# web services
bioservices
bioblend
bs4
# libraries to compute PCA
19
scikit-learn==0.20.3 #later versions do not support Python<3.5
20
scipy==1.2.1 #Scipy >=1.3 does not support Python<3.5
21
matplotlib==2.2.3 #Matplotlib 3.0+ does not support Python 2.x, 3.0, 3.1, 3.2, 3.3, or 3.4.
22
seaborn
23
# postgres driver
24
psycopg2-binary
25
git+https://gitlab.pasteur.fr/hmenager/django-diu.git#egg=django_diu
26
# openbabel is not installed from pip for now
27
28
#openbabel
django-crispy-forms
Hervé  MENAGER's avatar
Hervé MENAGER committed
29
celery