Commit 9cefc521 authored by Hervé  MENAGER's avatar Hervé MENAGER
Browse files

switch to Django2 and clean up requirements files

parent 3f8524c9
Pipeline #8991 failed with stages
in 10 minutes and 23 seconds
......@@ -191,7 +191,7 @@ class TestsForm(forms.Form):
activityRes_compound = forms.ChoiceField(widget=forms.Select(attrs={'class': 'form-control'}))
activityRes_test_modulation_type = forms.ModelChoiceField(queryset=CompoundActivityResult.objects.values_list('modulation_type', flat=True).distinct(), empty_label=None,widget=forms.Select(attrs={'class': 'form-control'}))
activityRes_activity_type = forms.CharField(widget=forms.TextInput(attrs={'class': 'form-control'}))
activityRes_activity = forms.IntegerField(forms.NumberInput(attrs={'class': 'form-control'}))
activityRes_activity = forms.IntegerField(widget=forms.NumberInput(attrs={'class': 'form-control'}))
activityRes_inhibition_percentage = forms.IntegerField(required=False)
cytotoxDesc_name=forms.ModelChoiceField(queryset=TestCytotoxDescription.objects.values_list('test_name', flat=True).distinct(), empty_label=None, widget=forms.Select(attrs={'class':'form-control'}))
cytotoxDesc_cell_line=forms.ModelChoiceField(queryset=CellLine.objects.all(), empty_label=None, widget=forms.Select(attrs={'class':'form-control'}),required=False)
......
-r requirements-core.txt
\ No newline at end of file
# django and extensions
Django>=2.1.5
django-extensions
django-formtools
django-debug-toolbar
django-allauth
# web services
bioservices
bioblend
bs4
# libraries to compute PCA
sklearn
scipy
matplotlib==2.2.3 #Matplotlib 3.0+ does not support Python 2.x, 3.0, 3.1, 3.2, 3.3, or 3.4.
# postgres driver
psycopg2
# openbabel is not installed from pip for now
#openbabel
\ No newline at end of file
-r requirements-core.txt
# documentation generation
sphinx
sphinx_rtd_theme
# dependencies to generate graph models using django-extensions
pygraphviz
pydot
pyparsing
\ No newline at end of file
-r requirements-core.txt
\ No newline at end of file
Django==1.11
django-bootstrap3
bioservices
#typing
django-extensions>=2.0.5
pygraphviz
pydot
pyparsing
django-formtools
django-debug-toolbar
mod_wsgi
bioblend
django-allauth==0.36
sklearn
scipy
matplotlib==2.2.3 #Matplotlib 3.0+ does not support Python 2.x, 3.0, 3.1, 3.2, 3.3, or 3.4.
psycopg2
openbabel
bs4
\ No newline at end of file
-r requirements.txt
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment