version 1.0 in incompatible with django 4.0